CISCO — Курс молодого бойца

На просторах интернета случайно наткнулся на хороший курс по сетевым технологиям. Я думаю, он будет полезен не только начинающим системным администраторам, но и опытным специалистам. Для систематизации, да и просто чтобы освежить в памяти некоторые вещи.

Курс молодого бойца. Практический курс с использованием CISCO PACKET TRACER

Ниже немного тезисно приведу некоторые моменты, которые хотелось бы записать для себя как шпаргалку, чтобы не пересматривать курс полностью и искать нужное место.

enable — переход в привилегированный режим

disable, exit — выход из привилигированного режима

<tab>, «?» — помощь при наборе команд

show run — просмотр конфигурации

do show run — просмотр конфигурации в режиме конфигурирования

conf t — переход в режим конфигурирования

Задаем пароль на вход в привилегированный режим

  1. вариант установки пароля
    enable password cisco
    conf t
    service password-encryption — зашифровать пароль в файле конфигурации
  2. вариант установки пароля
    conf t
    service password-encryption — это рекомендуют использовать
    enable secret cisco — лучше так заводить пароль, имеет больший приоритет чем первый вариант

Создаем пользователя

(config)# username admin privilege 15 password cisco

Устанавливаем авторизацию на подключение по консоли

(config)# line console 0

(config-line)# login local

Задаем IP-адрес устройства

В коммутаторах IP-адреса всегда настраиваются на логических интерфейсах

#conf t

(config)# interface Vlan1

(config-if)# ip address 192.168.0.1 255.255.255.0

(config-if)# no shutdown

(config-if)# exit

(config)# line vty 0 4

Выбираем тип удаленного подключения (telnet/ssh)

(config-line)# transport input telnet|ssh

Включаем авторизацию для удаленных подключений

(config-line)# login local

(config-line)# end

#write memory — не забываем сохранять конфигурацию

#wr mem — сокращенно

теперь через командную строку windows можно подключиться через telnet 192.168.0.1

 

Технология VLAN, создать их на коммутаторах, настроить access и trunk порты

> en

#conf t

(config)# vlan 2 — определяем vlan

(config-vlan)# name buh — даем имя vlan2 , пусть будет например бухгалтерия

(config-vlan)# exit

(config)# interface fastEthernet 0/1 — заходим в конфигурирование физического порта куда подключен комп, который нужно добавить во вновь созданный vlan

(config-if)# switchport mode access

(config-if)# switchport access vlan 2

на этом настройка порта закончена, т.е. этот порт теперь принадлежит vlan2

#show vlan — посмотреть настройки vlan

#show vlan brief

#show mac address-table  — посмотреть в коммутаторе таблицу mac -адресов, там тоже будет видно какой mac  в каком vlan

Соединение 2-х коммутаторов

Для их соединения лучше всего использовать самые производительные порты. Так как коммутаторы одного уровня модели OSI, то соединяем их кроссоверным патчкордом.

Необходимо настроить транк-порт. Этот порт позволяет разбить физическое соединение на несколько логических сегментов, т.е. в одной большой трубе идет обмен в маленьких шлангах :-)

#conf t

(config)# interface gigabitEthernet 1/1

(config-if)# switchport mode trunk — режим порта транковый

(config-if)# switchport trunk allowed vlan 2, 3 — разрешаем по транковому порту передачу vlan2 и vlan3

(config-if)# exit

wr mem — сохранить конфигурацию

Делаем это на каждом подключенном коммутаторе.

VLAN между собой могут общаться только есть коммутатор или маршрутизатор 3-го уровня, иначе никак из одного vlan не увидишь устройства в другом vlan!

Методы организации отказоустойчивых кналов связи

  • Резервирование соединений. Традиционная избыточная топология
  • Агрегирование каналов — объединение нескольких физических каналов в один логический

Spanning Tree Protocol (STP):

  • Протокол 2-го уровня модели OSI
  • Защита от петель в сети
  • Автоматическое резервирование каналов
  • Время сходимости (30-50 сек)
  • Альтернативы: RSTP, MSTP (менее секунды)

#show spanning-tree — посмотреть является ли коммутатор корневым

root выбирается у кого меньше mac-адрес, для того чтобы выбрать другой коммутатор корневым, есть команды:  spanning-tree vlan 1 root primary

Либо уменьшить приоритет командой: spanning-tree vla 1 priority 1

Для того, чтобы уменьшить время переключения необходимо использовать протокол RSTP

(config)# spanning-tree mode rapid-pvst

это делается на обоих коммутаторах. Теперь скорость переключения будет 1-2 сек.

Агрегирование каналов. Протокол EtherChannel.

Варианты:

  • Динамическое агрегирование
    • LACP (Ling Aggregation Control Protocol)
    • PagP (Port Aggregation Protocol)
  • Статическое агрегирование

Порты должны иметь одинаковые: скорость (spee), режим дуплекса (duplex mode), native VLAN, диапазон разрешенных VLAN, trunking status, тип интерфейса.

(config)#interface range fa0/1-2 — редактируем сразу 2 интерфейса

(config-if-range)# channel-group 1 mode on — создали один логический интерфейс, который объединяет 2 физических

Другой вариант, имеем 1 коммутатор 3560 и 3 коммутатора 2960.

На коммутаторе уровня распределения 3560

(config)# int range fa0/1-2

(config-if-range)# channel-protocol lacp

(config-if-range)# channel-group 1 mode active — создали интерфейс Port-Channel 1

(config)# int range fa0/3-4

(config-if-range)# channel-protocol lacp

(config-if-range)# channel-group 2 mode active — создали интерфейс Port-Channel 2

 

(config)# int range fa0/5-6

(config-if-range)# channel-protocol lacp

(config-if-range)# channel-group 3 mode active — создали интерфейс Port-Channel 3

Настраиваем коммутатор уровня доступа 2960

(config)# int range fa0/1-2

(config-if-range)# channel-protocol lacp

(config-if-range)# channel-group 1 mode passive

тоже самое делаем на оставшихся двух коммутаторах 2960

Посмотреть статус агрегированного порта, можно командой

#show etherchannel

, либо командой

#show etherchannel summary

#show etherchannel port-channel

trunk настраивается уже на на физических интерфейсах, а на логических Port-Channel, например

(config)# interface port-channel 1

(config-if)# switchport mode trunk

это нужно сделать на обоих коммутаторах.


 

Коммутаторы 2-го уровня модели OSI (L2)

  • Коммутируют трафик на основе MAC-адресов
  • Используются в качестве коммутаторов уровня доступа
  • Производят первичное сегментирование сети (VLAN)
  • Самая маленькая стоимость за порт/пользователя

Коммутаторы 3-го уровня модели OSI (L3)

  • IP маршрутизация
  • Агрегирование коммутаторов уровня доступа
  • Используются в качестве коммутаторов уровня распределения
  • Высокая производительность

les8

 

(config)# ip routing — маршрутизация между VLAN-ами на коммутаторе 3-го уровня

sl3

sl31

Статическая маршрутизация (Урок 10 подробнее)

(config)#ip route 192.168.22.0 255.255.255.0 192.168.55.2

(config)#ip route 192.168.33.0 255.255.255.0 192.168.55.2

(config)#ip route 192.168.4.0 255.255.255.0 192.168.55.2

Прописываем маршрут по умолчанию

(config)#ip route 0.0.0.0 0.0.0.0 192.168.70.1

#show ip route — посмотреть таблицу маршрутизации

lesson10

Урок 11. Использование DHCP

les11-1 les11-2

#ip helper-address 192.168.4.2

#show ip dhcp binding — посмотреть какие IP-адреса, каким компьютерам были выданы

les12-nat

#show ip nat translations

Cisco ASA 5505

les17

les18

les18-2

Во второй части урока, есть про настройку VPN на CISCO ASA 5505. Настройка немного отличается от настройки роутера.

les191

les20

les21

les22

les23

Заключение:

Автору большое спасибо! Курс мне понравился! Его контакты: Ольков Евгений — John Cooper netskills.ru cooper051@yandex.ru vk.com/netskills

Автор советует почитать:

  1. CBT Nuggets
  2. icnd1 icnd2
  3. CCNA Training
  4. www.examcollection.com — дампы экзаменов

Весь курс на ютубе http://www.youtube.com/playlist?list=PLcDkQ2Au8aVNYsqGsxRQxYyQijILa94T9